$re = '/[A-Z]{2}\d{8}/';
$str = 'AA12345698';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);