$re = '/^\d+\s\d+$/m';
$str = '0 2
0 abc
abcsd
abc 3';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;