$re = '/\'\K\/[^?]+/';
$str = '\'/photos/full/1/454/6454.jpg?20140521103415\',\'/photos/full/2/452/54_2.jpg?20140521104743\',\'/photos/full/3/254/C2454_3.jpg?20140521104744\'';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);