re = /^https:\/\/[^\/]+\/([^.]*)\.jpg/i
str = 'https://mydomainname.net/productimages/1679/T716AP1_lg.jpg?w=125&h=125&tstamp=05/19/2016%2015:08:30
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end