#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(0|[1-9]\d*)\.(0|[1-9]\d*)\.(0|[1-9]\d*)(?:-((?:\d*[a-zA-Z-][0-9a-zA-Z-]*|[1-9]\d*|0)(?:\.(?:\d*[a-zA-Z-][0-9a-zA-Z-]*|[1-9]\d*|0))*))"
Local $sString = "0.0.4" & @CRLF & _
"1.2.3" & @CRLF & _
"10.20.30" & @CRLF & _
"1.1.2-prerelease+meta" & @CRLF & _
"1.1.2+meta" & @CRLF & _
"1.1.2+meta-valid" & @CRLF & _
"1.0.0-alpha" & @CRLF & _
"1.0.0-beta" & @CRLF & _
"1.0.0-alpha.beta" & @CRLF & _
"1.0.0-alpha.beta.1" & @CRLF & _
"1.0.0-alpha.1" & @CRLF & _
"1.0.0-alpha0.valid" & @CRLF & _
"1.0.0-alpha.0valid" & @CRLF & _
"1.0.0-alpha-a.b-c-somethinglong+build.1-aef.1-its-okay" & @CRLF & _
"1.0.0-rc.1+build.1" & @CRLF & _
"2.0.0-rc.1+build.123" & @CRLF & _
"1.2.3-beta" & @CRLF & _
"10.2.3-DEV-SNAPSHOT" & @CRLF & _
"1.2.3-SNAPSHOT-123" & @CRLF & _
"1.0.0" & @CRLF & _
"2.0.0" & @CRLF & _
"1.1.7" & @CRLF & _
"2.0.0+build.1848" & @CRLF & _
"2.0.1-alpha.1227" & @CRLF & _
"1.0.0-alpha+beta" & @CRLF & _
"1.2.3----RC-SNAPSHOT.12.9.1--.12+788" & @CRLF & _
"1.2.3----R-S.12.9.1--.12+meta" & @CRLF & _
"1.2.3----RC-SNAPSHOT.12.9.1--.12" & @CRLF & _
"1.0.0+0.build.1-rc.10000aaa-kk-0.1" & @CRLF & _
"99999999999999999999999.999999999999999999.99999999999999999" & @CRLF & _
"1.0.0-0A.is.legal" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")