re = /^\s*(([+-]?((0|[1-9][0-9]*)(\.[0-9]*)?|\.[0-9]+)([Ee][+-]?[0-9]+)?)\s+){15}([+-]?((0|[1-9][0-9]*)(\.[0-9]*)?|\.[0-9]+)([Ee][+-]?[0-9]+)?)\s*$/m
str = '0 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end