$re = '/^\d{2,4}-\d{1,2}-\d{1,2}/m';
$str = '2012-09-25 ag.pdf
12-09-25 ag.pdf
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);