import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "199\\d{1}|20\\d{2}|\\d{2}(?![/,\\-\\w ])";
final String string = "04/20/2001; 04/20/11; 4/20/09; 4/3/01\n"
+ "Mar-20-2001; Dec 20, 2009; April 20, 2009; Mar. 20, 2009; Mar 20 2009;\n"
+ "20 Mar 2001; 20 April 2001; 20 Mar. 2007; 20 March, 2009\n"
+ "Mar 21th, 2009; Mar 21st, 2009; Feb 22nd, 2002\n"
+ "Feb 2009; Sep 2009; Nov 2016\n"
+ "6/2008; 12/2009\n"
+ "2003; 2012";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}