package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).+?\]\]`)
var str = `Floor_Live_Patterened_SpanPairs_1: [[-3, 0, 0, 5.5], [-3, 5.5, 0, .5]]
Floor_Live_Patterened_SpanPairs_2: [[-3, 0, 0, 5.5], [-3, 9.5, 0, 13.5]]
Floor_Live_Patterened_SpanPairs_3: [[-3, 5.5, 0, 9.5], [-3, 9.5, 0, 13.5]]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}