package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b\d+\b|(\d)`)
var str = `my text contains of the 33109 following values RT3123SO55 and also with certain numbers godwil_5708 and 323stwe and 8y9yc2 456453`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}