#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)VARIABLE(?:(?!VARIABLE).)*"
Local $sString = "VARIABLE: GRP1.SGRP1.100:VAR1" & @CRLF & _
"" & @CRLF & _
"Timestamp (LOCAL_TIME),Value" & @CRLF & _
"2018-07-18 13:52:09.100,25582" & @CRLF & _
"2018-07-18 13:52:49.900,24048" & @CRLF & _
"VARIABLE: GRP1.SGRP2.102:VAR1" & @CRLF & _
"" & @CRLF & _
"Timestamp (LOCAL_TIME),Value" & @CRLF & _
"2018-07-18 13:52:09.100,25582" & @CRLF & _
"2018-07-18 13:52:49.900,24048"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")