$re = '/\.[^.]+\.\K.+$/m';
$str = 'ATL.556808.UMO20.02';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);