import Foundation
let pattern = #"(\d{5})[ ]{1,3}(\d{4})[ ]{1,3}([0-9.]{4})[ ]{1,3}(([0-9.]{4}))[ ]{1,3}([0-9.]{3})[ ]{1,3}([0-9.]{4})[ ]{1,3}([0-9.]{3})[ ]{1,3}([0-9.]{3})[ ]{1,3}([0-9.]{3})[ ]{1,3}([0-9.]{4})[ ]{1,3}([0-9.]{4})[ ]{1,3}([0-9.]{4})[ ]{1,3}([0-9.]{4})[ ]{1,3}([0-9.]{4})"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"20046 2005 27.0 44.3 9.0 15.9 3.6 9.2 9.2 37.5 18.3 18.6 24.4 26.0"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)