package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\w*(\.([a-zA-Z0-9]+[-_]+)?careerfy([-_]+[a-zA-Z0-9]+)?)\w*`)
var str = `.crfy-careerfy { display: none}
.careerfy { font-size: 12; font-family: "arial"}
.crfy-careerfyds-add-space {background-color: red}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}