use strict;
my $str = '<!-- @[Hero] -->
# Creating new contexts
<!-- @[UsageExample] -->
## Usage example
```javascript
Import { ICON_NAME } from \'Icons\'
```
<!-- @[/Hero] -->
<!-- @[ArticleSection] -->
## Section Title
### Section subtitle that contains additional information
Cillum ipsum ad veniam elit non. Sunt ea ut quis qui dolore id voluptate magna. Ex non commodo reprehenderit ipsum irure. Ad excepteur nulla ullamco et deserunt magna et sint reprehenderit sint esse commodo. Tempor duis anim nisi commodo incididunt ut ex et sunt laborum excepteur ea culpa laborum.
<!-- @[NoteBlock(warning)] -->
> #### Be Careful
> Eu laboris eiusmod ut exercitation minim laboris ipsum magna consectetur est [commodo](/nope).
<!-- @[/NoteBlock] -->
Officia esse Lorem ad duis dolore nostrud ex elit aliqua incididunt sint ad ex. Eiusmod do in ad aute nulla eiusmod tempor Lorem non. Qui sunt voluptate laborum mollit elit adipisicing minim dolore voluptate veniam incididunt proident ullamco. Ipsum est cupidatat occaecat pariatur ut aute.
<!-- @[CodeExample] -->
#### Code example
```javascript
class ScrollingList extends React.Component {
constructor(props) {
super(props);
this.listRef = React.createRef();
}
render() {
return (
<div ref={this.listRef}>{/* ...contents... */}</div>
);
}
}
```
<!-- @[PropsTable] -->
#### Props
Prop Name | Value | Required
--------- | ----- | --------
**label** | `{String}` | true
**state** | `default` `secondary` `info` `warning` `danger` | false
**size** | `xs` `s` `m` `l` `xl` | false
**disabled** | `-` | false
<!-- @[/ArticleSection] -->
';
my $regex = qr/<!-- @\[(?<component>[\w+]+)\(*(?<classes>[\w+]+)*\)*\] -->/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}