const regex = new RegExp('\\b(?P<town>(?:[A-Za-zéÉã]+\\s)+)\\D+(?P<number>\\d+)', 'gm')
const str = `Lisboa 187
Santo Tirso 8
Porto 137 Vila do Conde
8
Maia
119 Penafiel
7
Vila Nova de Gaia
83 Portimão
7
Oliveira de Azeméis 18 Évora
5
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}