re = /\b(\p{Lu}[\p{Lu}+\p{Ll}]*\p{Lu}*)|(\p{Lu}*[\p{Lu}+\p{Ll}]*\p{Lu}+)\b/m
str = 'hello world at MSDN Magazie published in LaTeX Format tomaX Tomax TMa TMAx TmAX toTHE '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end