using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\s?(\p{Lu}[\p{Lu}+\p{Ll}]*\p{Lu}*)|(\p{Lu}*[\p{Lu}+\p{Ll}]*\p{Lu}+)\s?";
string input = @"hello world at MSDN Magazine published in LaTeX Format tomaX Tomax TMa TMAx TmAX toTHE ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}