import re
regex = re.compile(r"\shref=([\"'])(.*?)\1")
test_str = ("<ul>\n"
"<li><a href=\"/page/\">pag2 </a></li><li><a href=\"/page/\">pag2 </a></li><li><a href=\"/page/\">pag2 </a></li>\n"
"</ul>\n\n"
"href=\"pgae/?p=1&b=2#33\" \n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")