$re = '/\$\{([^{}]*)}/';
$str = 'text1${text2${text3}text4}text5';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);