$re = '/^(.*)$(?:(?<=^(?:(?:[^a]*?a){1})?[^a]*)(?<=^(?:(?:[^b]*?b){1})?[^b]*)(?<=^(?:(?:[^c]*?c){1})?[^c]*)(?<=^(?:(?:[^d]*?d){1})?[^d]*)(?<=^(?:(?:[^e]*?e){1})?[^e]*)(?<=^(?:(?:[^f]*?f){1})?[^f]*)(?<=^(?:(?:[^g]*?g){1})?[^g]*)(?<=^(?:(?:[^h]*?h){1})?[^h]*)(?<=^(?:(?:[^i]*?i){1})?[^i]*)(?<=^(?:(?:[^j]*?j){1})?[^j]*)(?<=^(?:(?:[^k]*?k){1})?[^k]*)(?<=^(?:(?:[^l]*?l){1})?[^l]*)(?<=^(?:(?:[^m]*?m){1})?[^m]*)(?<=^(?:(?:[^n]*?n){1})?[^n]*)(?<=^(?:(?:[^o]*?o){1})?[^o]*)(?<=^(?:(?:[^p]*?p){1})?[^p]*)(?<=^(?:(?:[^q]*?q){1})?[^q]*)(?<=^(?:(?:[^r]*?r){1})?[^r]*)(?<=^(?:(?:[^s]*?s){1})?[^s]*)(?<=^(?:(?:[^t]*?t){1})?[^t]*)(?<=^(?:(?:[^u]*?u){1})?[^u]*)(?<=^(?:(?:[^v]*?v){1})?[^v]*)(?<=^(?:(?:[^w]*?w){1})?[^w]*)(?<=^(?:(?:[^x]*?x){1})?[^x]*)(?<=^(?:(?:[^y]*?y){1})?[^y]*)|(?<=^(?:(?:[^a]*?a){2})?[^a]*)(?<=^(?:(?:[^b]*?b){2})?[^b]*)(?<=^(?:(?:[^c]*?c){2})?[^c]*)(?<=^(?:(?:[^d]*?d){2})?[^d]*)(?<=^(?:(?:[^e]*?e){2})?[^e]*)(?<=^(?:(?:[^f]*?f){2})?[^f]*)(?<=^(?:(?:[^g]*?g){2})?[^g]*)(?<=^(?:(?:[^h]*?h){2})?[^h]*)(?<=^(?:(?:[^i]*?i){2})?[^i]*)(?<=^(?:(?:[^j]*?j){2})?[^j]*)(?<=^(?:(?:[^k]*?k){2})?[^k]*)(?<=^(?:(?:[^l]*?l){2})?[^l]*)(?<=^(?:(?:[^m]*?m){2})?[^m]*)(?<=^(?:(?:[^n]*?n){2})?[^n]*)(?<=^(?:(?:[^o]*?o){2})?[^o]*)(?<=^(?:(?:[^p]*?p){2})?[^p]*)(?<=^(?:(?:[^q]*?q){2})?[^q]*)(?<=^(?:(?:[^r]*?r){2})?[^r]*)(?<=^(?:(?:[^s]*?s){2})?[^s]*)(?<=^(?:(?:[^t]*?t){2})?[^t]*)(?<=^(?:(?:[^u]*?u){2})?[^u]*)(?<=^(?:(?:[^v]*?v){2})?[^v]*)(?<=^(?:(?:[^w]*?w){2})?[^w]*)(?<=^(?:(?:[^x]*?x){2})?[^x]*)(?<=^(?:(?:[^y]*?y){2})?[^y]*)|(?<=^(?:(?:[^a]*?a){3})?[^a]*)(?<=^(?:(?:[^b]*?b){3})?[^b]*)(?<=^(?:(?:[^c]*?c){3})?[^c]*)(?<=^(?:(?:[^d]*?d){3})?[^d]*)(?<=^(?:(?:[^e]*?e){3})?[^e]*)(?<=^(?:(?:[^f]*?f){3})?[^f]*)(?<=^(?:(?:[^g]*?g){3})?[^g]*)(?<=^(?:(?:[^h]*?h){3})?[^h]*)(?<=^(?:(?:[^i]*?i){3})?[^i]*)(?<=^(?:(?:[^j]*?j){3})?[^j]*)(?<=^(?:(?:[^k]*?k){3})?[^k]*)(?<=^(?:(?:[^l]*?l){3})?[^l]*)(?<=^(?:(?:[^m]*?m){3})?[^m]*)(?<=^(?:(?:[^n]*?n){3})?[^n]*)(?<=^(?:(?:[^o]*?o){3})?[^o]*)(?<=^(?:(?:[^p]*?p){3})?[^p]*)(?<=^(?:(?:[^q]*?q){3})?[^q]*)(?<=^(?:(?:[^r]*?r){3})?[^r]*)(?<=^(?:(?:[^s]*?s){3})?[^s]*)(?<=^(?:(?:[^t]*?t){3})?[^t]*)(?<=^(?:(?:[^u]*?u){3})?[^u]*)(?<=^(?:(?:[^v]*?v){3})?[^v]*)(?<=^(?:(?:[^w]*?w){3})?[^w]*)(?<=^(?:(?:[^x]*?x){3})?[^x]*)(?<=^(?:(?:[^y]*?y){3})?[^y]*)|(?<=^(?:(?:[^a]*?a){4})?[^a]*)(?<=^(?:(?:[^b]*?b){4})?[^b]*)(?<=^(?:(?:[^c]*?c){4})?[^c]*)(?<=^(?:(?:[^d]*?d){4})?[^d]*)(?<=^(?:(?:[^e]*?e){4})?[^e]*)(?<=^(?:(?:[^f]*?f){4})?[^f]*)(?<=^(?:(?:[^g]*?g){4})?[^g]*)(?<=^(?:(?:[^h]*?h){4})?[^h]*)(?<=^(?:(?:[^i]*?i){4})?[^i]*)(?<=^(?:(?:[^j]*?j){4})?[^j]*)(?<=^(?:(?:[^k]*?k){4})?[^k]*)(?<=^(?:(?:[^l]*?l){4})?[^l]*)(?<=^(?:(?:[^m]*?m){4})?[^m]*)(?<=^(?:(?:[^n]*?n){4})?[^n]*)(?<=^(?:(?:[^o]*?o){4})?[^o]*)(?<=^(?:(?:[^p]*?p){4})?[^p]*)(?<=^(?:(?:[^q]*?q){4})?[^q]*)(?<=^(?:(?:[^r]*?r){4})?[^r]*)(?<=^(?:(?:[^s]*?s){4})?[^s]*)(?<=^(?:(?:[^t]*?t){4})?[^t]*)(?<=^(?:(?:[^u]*?u){4})?[^u]*)(?<=^(?:(?:[^v]*?v){4})?[^v]*)(?<=^(?:(?:[^w]*?w){4})?[^w]*)(?<=^(?:(?:[^x]*?x){4})?[^x]*)(?<=^(?:(?:[^y]*?y){4})?[^y]*)|(?<=^(?:(?:[^a]*?a){5})?[^a]*)(?<=^(?:(?:[^b]*?b){5})?[^b]*)(?<=^(?:(?:[^c]*?c){5})?[^c]*)(?<=^(?:(?:[^d]*?d){5})?[^d]*)(?<=^(?:(?:[^e]*?e){5})?[^e]*)(?<=^(?:(?:[^f]*?f){5})?[^f]*)(?<=^(?:(?:[^g]*?g){5})?[^g]*)(?<=^(?:(?:[^h]*?h){5})?[^h]*)(?<=^(?:(?:[^i]*?i){5})?[^i]*)(?<=^(?:(?:[^j]*?j){5})?[^j]*)(?<=^(?:(?:[^k]*?k){5})?[^k]*)(?<=^(?:(?:[^l]*?l){5})?[^l]*)(?<=^(?:(?:[^m]*?m){5})?[^m]*)(?<=^(?:(?:[^n]*?n){5})?[^n]*)(?<=^(?:(?:[^o]*?o){5})?[^o]*)(?<=^(?:(?:[^p]*?p){5})?[^p]*)(?<=^(?:(?:[^q]*?q){5})?[^q]*)(?<=^(?:(?:[^r]*?r){5})?[^r]*)(?<=^(?:(?:[^s]*?s){5})?[^s]*)(?<=^(?:(?:[^t]*?t){5})?[^t]*)(?<=^(?:(?:[^u]*?u){5})?[^u]*)(?<=^(?:(?:[^v]*?v){5})?[^v]*)(?<=^(?:(?:[^w]*?w){5})?[^w]*)(?<=^(?:(?:[^x]*?x){5})?[^x]*)(?<=^(?:(?:[^y]*?y){5})?[^y]*)|(?<=^(?:(?:[^a]*?a){6})?[^a]*)(?<=^(?:(?:[^b]*?b){6})?[^b]*)(?<=^(?:(?:[^c]*?c){6})?[^c]*)(?<=^(?:(?:[^d]*?d){6})?[^d]*)(?<=^(?:(?:[^e]*?e){6})?[^e]*)(?<=^(?:(?:[^f]*?f){6})?[^f]*)(?<=^(?:(?:[^g]*?g){6})?[^g]*)(?<=^(?:(?:[^h]*?h){6})?[^h]*)(?<=^(?:(?:[^i]*?i){6})?[^i]*)(?<=^(?:(?:[^j]*?j){6})?[^j]*)(?<=^(?:(?:[^k]*?k){6})?[^k]*)(?<=^(?:(?:[^l]*?l){6})?[^l]*)(?<=^(?:(?:[^m]*?m){6})?[^m]*)(?<=^(?:(?:[^n]*?n){6})?[^n]*)(?<=^(?:(?:[^o]*?o){6})?[^o]*)(?<=^(?:(?:[^p]*?p){6})?[^p]*)(?<=^(?:(?:[^q]*?q){6})?[^q]*)(?<=^(?:(?:[^r]*?r){6})?[^r]*)(?<=^(?:(?:[^s]*?s){6})?[^s]*)(?<=^(?:(?:[^t]*?t){6})?[^t]*)(?<=^(?:(?:[^u]*?u){6})?[^u]*)(?<=^(?:(?:[^v]*?v){6})?[^v]*)(?<=^(?:(?:[^w]*?w){6})?[^w]*)(?<=^(?:(?:[^x]*?x){6})?[^x]*)(?<=^(?:(?:[^y]*?y){6})?[^y]*)|(?<=^(?:(?:[^a]*?a){7})?[^a]*)(?<=^(?:(?:[^b]*?b){7})?[^b]*)(?<=^(?:(?:[^c]*?c){7})?[^c]*)(?<=^(?:(?:[^d]*?d){7})?[^d]*)(?<=^(?:(?:[^e]*?e){7})?[^e]*)(?<=^(?:(?:[^f]*?f){7})?[^f]*)(?<=^(?:(?:[^g]*?g){7})?[^g]*)(?<=^(?:(?:[^h]*?h){7})?[^h]*)(?<=^(?:(?:[^i]*?i){7})?[^i]*)(?<=^(?:(?:[^j]*?j){7})?[^j]*)(?<=^(?:(?:[^k]*?k){7})?[^k]*)(?<=^(?:(?:[^l]*?l){7})?[^l]*)(?<=^(?:(?:[^m]*?m){7})?[^m]*)(?<=^(?:(?:[^n]*?n){7})?[^n]*)(?<=^(?:(?:[^o]*?o){7})?[^o]*)(?<=^(?:(?:[^p]*?p){7})?[^p]*)(?<=^(?:(?:[^q]*?q){7})?[^q]*)(?<=^(?:(?:[^r]*?r){7})?[^r]*)(?<=^(?:(?:[^s]*?s){7})?[^s]*)(?<=^(?:(?:[^t]*?t){7})?[^t]*)(?<=^(?:(?:[^u]*?u){7})?[^u]*)(?<=^(?:(?:[^v]*?v){7})?[^v]*)(?<=^(?:(?:[^w]*?w){7})?[^w]*)(?<=^(?:(?:[^x]*?x){7})?[^x]*)(?<=^(?:(?:[^y]*?y){7})?[^y]*)|(?<=^(?:(?:[^a]*?a){8})?[^a]*)(?<=^(?:(?:[^b]*?b){8})?[^b]*)(?<=^(?:(?:[^c]*?c){8})?[^c]*)(?<=^(?:(?:[^d]*?d){8})?[^d]*)(?<=^(?:(?:[^e]*?e){8})?[^e]*)(?<=^(?:(?:[^f]*?f){8})?[^f]*)(?<=^(?:(?:[^g]*?g){8})?[^g]*)(?<=^(?:(?:[^h]*?h){8})?[^h]*)(?<=^(?:(?:[^i]*?i){8})?[^i]*)(?<=^(?:(?:[^j]*?j){8})?[^j]*)(?<=^(?:(?:[^k]*?k){8})?[^k]*)(?<=^(?:(?:[^l]*?l){8})?[^l]*)(?<=^(?:(?:[^m]*?m){8})?[^m]*)(?<=^(?:(?:[^n]*?n){8})?[^n]*)(?<=^(?:(?:[^o]*?o){8})?[^o]*)(?<=^(?:(?:[^p]*?p){8})?[^p]*)(?<=^(?:(?:[^q]*?q){8})?[^q]*)(?<=^(?:(?:[^r]*?r){8})?[^r]*)(?<=^(?:(?:[^s]*?s){8})?[^s]*)(?<=^(?:(?:[^t]*?t){8})?[^t]*)(?<=^(?:(?:[^u]*?u){8})?[^u]*)(?<=^(?:(?:[^v]*?v){8})?[^v]*)(?<=^(?:(?:[^w]*?w){8})?[^w]*)(?<=^(?:(?:[^x]*?x){8})?[^x]*)(?<=^(?:(?:[^y]*?y){8})?[^y]*)|(?<=^(?:(?:[^a]*?a){9})?[^a]*)(?<=^(?:(?:[^b]*?b){9})?[^b]*)(?<=^(?:(?:[^c]*?c){9})?[^c]*)(?<=^(?:(?:[^d]*?d){9})?[^d]*)(?<=^(?:(?:[^e]*?e){9})?[^e]*)(?<=^(?:(?:[^f]*?f){9})?[^f]*)(?<=^(?:(?:[^g]*?g){9})?[^g]*)(?<=^(?:(?:[^h]*?h){9})?[^h]*)(?<=^(?:(?:[^i]*?i){9})?[^i]*)(?<=^(?:(?:[^j]*?j){9})?[^j]*)(?<=^(?:(?:[^k]*?k){9})?[^k]*)(?<=^(?:(?:[^l]*?l){9})?[^l]*)(?<=^(?:(?:[^m]*?m){9})?[^m]*)(?<=^(?:(?:[^n]*?n){9})?[^n]*)(?<=^(?:(?:[^o]*?o){9})?[^o]*)(?<=^(?:(?:[^p]*?p){9})?[^p]*)(?<=^(?:(?:[^q]*?q){9})?[^q]*)(?<=^(?:(?:[^r]*?r){9})?[^r]*)(?<=^(?:(?:[^s]*?s){9})?[^s]*)(?<=^(?:(?:[^t]*?t){9})?[^t]*)(?<=^(?:(?:[^u]*?u){9})?[^u]*)(?<=^(?:(?:[^v]*?v){9})?[^v]*)(?<=^(?:(?:[^w]*?w){9})?[^w]*)(?<=^(?:(?:[^x]*?x){9})?[^x]*)(?<=^(?:(?:[^y]*?y){9})?[^y]*))/m';
$str = 'arraigning
nonordered
abadbacdcacbdbdc
mesosome
unreverberating
museums
reparticipate
dwqwe2';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);