$re = '/^[^+\s]{3,}(?:\+[^+\s]{3,})*$/m';
$str = 'sss
sdfsgdf
4534534
dfs34543
sdafds+3232+sfdsafd
qwe+sdf
234+567
cvb+243
jc + fjewif + fjeie
a
aa
a+
aa+
+aa
+a
a+a
aa+aa
aaa+a';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);