re = /(<a[^<]*?><\/a>)/m
str = '<a href="this-goes-somewhere.com" rel="external"></a>
<a href="go-to-that-page.html"></a>
<a href="this-should-stay.html">This Should Stay</a>
<a href="this-should-stay.html"><img src="kitten.jpg"/></a>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end