import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\b(?:\\w+)?\\d+(?:\\w+)?(?:[\\-\\/])?(?:\\w+)?(?:\\d+)?\\b)";
final String string = "Park Avenue number 100\n"
+ "Baker Street number 100\n"
+ "Baker Street 100\n"
+ "The bakery shop is located on 109-111 Wharfside Street\n"
+ "My mother's house is on 40-42 Parkway\n"
+ "My schoolmate lives in 25b-26 Sun Street\n"
+ "The apartment is located on R2-R3 City Quay\n"
+ "I live in 43a Garden Walk\n"
+ "I live in 6/7 Marine Road\n"
+ "I live in 10-12 Acacia Ave\n"
+ "I live in 4513 3RD STREET CIRCLE WEST\n"
+ "I live in 1/2 Fifth Avenue\n"
+ "number C3-H4 sawojajar Malang";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}