#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([BRAS])(?!\1)([BRAS])(?!\1|\2)([BRAS])(?!\1|\2|\3)([BRAS])"
Local $sString = "BRASIL" & @CRLF & _
"BSRAIL" & @CRLF & _
"BARSILERO" & @CRLF & _
"BRASILERA" & @CRLF & _
"BRASILEÑA" & @CRLF & _
"BRASILEÑO" & @CRLF & _
"BARBADOS" & @CRLF & _
"BOSNIA AND HERZEGOVINA"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")