$re = '/(\.|\?|!)\p{L}/';
$str = 'Тест! Тест. Тест?
Тест!Тест.Тест?
Test! Test. Test?
Test!Test.Test?';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);