const regex = /(\w).*\1/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\w).*\\1', 'gm')
const str = `nice
uncopyrightable
test
foo
sentinel`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);