$re = '/\b(?<!-)\d+\./m';
$str = '1.This is example of regex and call the mobile 400-199-1234.This statement is valid.2.This is second example of regex.10.This is tenth statement';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;