re = /(\b)?term(?(1)|\b)/
str = 'a term is
the terms are
the midterm was
the midterms were'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end