$re = '/^[^#.]*#[^.#]+\.[^.#]*$/m';
$str = 'abc#.123
abc#12.3
abc#abcd.23
a#123.12
a#12123124.12
abcd#1231.09
1.23#12312.01
123#122.01#12';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);