$re = '/\(([0-9]*) (\+|\*) ([0-9]*)\)/m';
$str = '1 + (2 * 3) + (4 * (5 + 6))';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);