re = /^
(?P<name>
(?:(?P<domain>(?:(?:localhost|[\w-]+(?:\.[\w-]+)+)(?::\d+)?)|[\w]+:\d+)\/)?
(?P<image>[a-z0-9_.-]+(?:\/[a-z0-9_.-]+)*)
)
(?::(?P<tag>[\w][\w.-]{0,127}))?
(?:@(?P<digest>[A-Za-z][A-Za-z0-9]*(?:[+.-_][A-Za-z][A-Za-z0-9]*)*:[0-9a-fA-F]{32,}))?
$/xim
str = 'alpine
alpine:latest
library/alpine
localhost/test
localhost:1234/test
test:1234/bla
alpine:3.7
docker.example.com/gmr/alpine:3.7
docker.example.com/gmr/alpine/test2:3.7
docker.example.com/gmr/alpine/test2/test3:3.7
docker.example.com:5000/gmr/alpine:latest
docker.example.com:5000/gmr/alpine:latest@sha256:5ae13221a775e9ded1d00f4dd6a3ad869ed1d662eb8cf81cb1fc2ba06f2b7172
docker.example.com:5000/gmr/alpine/test2:latest@sha256:5ae13221a775e9ded1d00f4dd6a3ad869ed1d662eb8cf81cb1fc2ba06f2b7172
docker.example.com/gmr/alpine/test2:latest@sha256:5ae13221a775e9ded1d00f4dd6a3ad869ed1d662eb8cf81cb1fc2ba06f2b7172
docker.example.com/gmr/alpine/test2@sha256:5ae13221a775e9ded1d00f4dd6a3ad869ed1d662eb8cf81cb1fc2ba06f2b7172
portainer/portainer:latest
registry:2@sha256:5a156ff125e5a12ac7fdec2b90b7e2ae5120fa249cf62248337b6d04abc574c8'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end