$re = '/^(?:[^-]*-){3}(.)/m';
$str = 'SSS-TEST-01-TEST1';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);