package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\d+\.)?\d+:(\d+\.)?\d+$`)
var str = `.4:.9
0.4:0.9
4:9`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}