#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(time_(?:namelookup|connect|pretransfer|redirect|starttransfer|total))\s*:\s*([+-]?(?:\d*,)?\d+)"
Local $sString = "time_namelookup: 0,121668 " & @CRLF & _
"time_connect: 0,460643 " & @CRLF & _
"time_pretransfer: 0,460755 " & @CRLF & _
"time_redirect: 0,000000 " & @CRLF & _
"time_starttransfer: 0,811697 " & @CRLF & _
"time_total: 0,811813 " & @CRLF & _
"-------------" & @CRLF & _
"time_namelookup: 0,121665 " & @CRLF & _
"time_connect: 0,460643 " & @CRLF & _
"time_pretransfer: 0,460355 " & @CRLF & _
"time_redirect: 0,000000 " & @CRLF & _
"time_starttransfer: 0,813697 " & @CRLF & _
"time_total: 0,811853 " & @CRLF & _
"-------------" & @CRLF & _
"time_namelookup: 0,121558 " & @CRLF & _
"time_connect: 0,463243 " & @CRLF & _
"time_pretransfer: 0,460755 " & @CRLF & _
"time_redirect: 0,000000 " & @CRLF & _
"time_starttransfer: 0,911697 " & @CRLF & _
"time_total: 0,811413 "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")