package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[\+\d]?(?:[\d-.\s()]*)$`)
var str = `+123456789
1234t1234tassd
123456789`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}