#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx)# Chunk or note time." & @CRLF & _
"(?<= \| ) " & @CRLF & _
" (?: \s+) (\() ([0-2][0-9]) (:) ([0-5][0-9]) (\)) " & @CRLF & _
"(?= \s+ \|)" & @CRLF & _
"|" & @CRLF & _
"" & @CRLF & _
"# Revision title." & @CRLF & _
"(?<= \s \| \s) " & @CRLF & _
" (\(.+\s\#\d+\)) " & @CRLF & _
"(?= \s+ \|)" & @CRLF & _
"|" & @CRLF & _
"" & @CRLF & _
"# Chunk title." & @CRLF & _
"(?<= \| \s [0-2][0-9] : [0-5][0-9] - [0-2][0-9] : [0-5][0-9] \s \| \s ) " & @CRLF & _
" (?! \[ | \s* \| ) " & @CRLF & _
" (?:\s*)? (.+?) " & @CRLF & _
"(?= \s+ \|)" & @CRLF & _
"|" & @CRLF & _
"" & @CRLF & _
"# Chunk note." & @CRLF & _
"(?<= \s \| \s ) (?! -{2} )" & @CRLF & _
"(- .+?)" & @CRLF & _
"(?= \s+ \|)"
Local $sString = "[^\S\n] (?:\s*\r\n|\s*\r|\s*\n)" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"# Time block" & @CRLF & _
"" & @CRLF & _
"| Time | Block |" & @CRLF & _
"| ----------: | :---------------- |" & @CRLF & _
"| (00:00) | (Revision #1) |" & @CRLF & _
"| | |" & @CRLF & _
"| 00:00-00:00 | Chunk |" & @CRLF & _
"| | - Note w/ details |" & @CRLF & _
"| 00:00-00:00 | Some meeting |" & @CRLF & _
"| 11:00-13:00 | Chunk |" & @CRLF & _
"| 13:00 | - Note w/ details |" & @CRLF & _
"| | |" & @CRLF & _
"| (00:00) | (Revision #1) |" & @CRLF & _
"| 00:00-00:00 | Chunk |" & @CRLF & _
"| | - Note w/ details |" & @CRLF & _
"" & @CRLF & _
"## Time Tracking" & @CRLF & _
"" & @CRLF & _
"| Tracker | Task | Backlog |" & @CRLF & _
"| ----------: | :---------------------------------- | :------------ |" & @CRLF & _
"| 08:04-08:53 | [x] * Task for deep work block (#1) | [[wiki.link]] |" & @CRLF & _
"| 09:07-09:56 | | Don't match |" & @CRLF & _
"| 98m | | |" & @CRLF & _
"| | | |" & @CRLF & _
"| 00:00-00:00 | Can Match | |" & @CRLF & _
"| | Don't Match | |" & @CRLF & _
"| 00:00-00:00 | | Don't match |" & @CRLF & _
"" & @CRLF & _
"Group 1: `(` for time" & @CRLF & _
"Group 2: `00` hour (for chunk)" & @CRLF & _
"Group 3: `:` (for chunk)" & @CRLF & _
"Group 4: `00` minute (for chunk)" & @CRLF & _
"Group 5: `)` for time" & @CRLF & _
"Group 6: `(Revision #1)`" & @CRLF & _
"Group 7: `Chunk`or `Some meeting`" & @CRLF & _
"Group 8: `- Note w/ details`" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")