package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(@@.*)\/(.*)_(REQUEST|SUCCESS|FAILURE)\/?(.*)?\/?(.*)?\/?(.*)?`)
var str = `@@calendar/FETCH_EVENT_SUCCESS`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}