# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"((\+|\d|\(|(<.*?>))[\d\-\(\)\. ]{9,}(\.|\n| |<\/.*>)(?!(png|jpg|<)))"
test_str = ("Приветствую! \n"
"Можете помочь составить регулярное выражение чтобы вырезать номера телефонов из текста?\n"
"Для чего это нужно?\n"
"Для вырезки из текста формы сообщения - телефонов спамеров.\n"
"<p style=\"text-align: center;\">(333) 4444 4444</p>\n"
"<span style=\"text-align: center;\">1234567890</span>\n"
"<li style=\"text-align: center;\">(999) 9 888 7777</li>\n"
"<p style=\"text-align: left;\">12345 1234</p>\n"
"Вариантов написания телефонов +22 (999) 555-66-29 достаточно много.\n"
"Как учесть все варианты я не понимаю.\n"
"Телефоны имеют разное количество цифр: 10, 11, 12.\n"
"Разное написание:\n"
"+7 999 999 99 99 \n"
"7 999 999 99 99\n"
"+7999 999 99 99\n"
"7999 999 99 99\n"
"+7999-999-99-99\n"
"+7 999 999 99 99 \n"
"7999-999-99-99\n"
"+7999-999-9999\n"
"7999-999-9999\n"
"+7999-9999999\n"
"7999-9999999\n"
"+79999999999\n"
"79999999999\n"
"+7.999.999.99.99\n"
"+7(999) 999-99-99\n"
"+123 (999) 555-66-29\n"
"1_2017092902182426089.jpg\n"
"123451_2017092902182426089.png\n"
"6644123451_2017092902182426089.png\n\n"
"и вместо цифры страны с оной цифрой 7, есть коды по 2 и по 3 цифры. 7999659999999 jgjhgjkgjk\n"
"Можно придумать и ещё много вариантов написания номера телефона.\n"
"Как это +7.999.999.99.99 всё учесть в выражении?\n"
"В тексте могут содержаться ссылки +555 (999) 555-66-29 на фотографии и ссылки на страницы сайта, в которых могут быть цифры. Как не зацепить цифры в ссылках? Как их отсортировать от номеров телефонов?\n"
"Можете помочь?")
subst = "-kill-"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.IGNORECASE | re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.