re = /(?:\(\d{3}\)*\s\d{3}-\d{4})|(?:\d{3}(?:-|\s*)\d{3}-\d{4})|(?:\d{10})/m
str = '801-555-6432
(801) 556-9023
702 556-9023
7025569023
(801)556-9023'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end