re = /(\d{4}-\d{2}-\d{2})[A-Z]+(\d{2}:\d{2}:\d{2}).([0-9+-:]+)/m
str = '2013-08-11T17:22:04.51+01:00'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end