$re = '/(?>[^:]+:){6}([^:]+)/m';
$str = 'diamond:dev:liquid:beta:1069:zone:2929';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);