re = /^([^\r\n|]*(?:\|(?!\|)[^\r\n|]*)*)(?:\|\|(.+))?$/m
str = 'Some words
Some another words||MyTag'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end