package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\p{C}+`)
var str = `word without control characters
word with control character between`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}