#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^[\s\S]*?(?=\n{2,})"
Local $sString = "The War of the Worlds" & @CRLF & _
"10-10-2020" & @CRLF & _
"" & @CRLF & _
"I." & @CRLF & _
"THE EVE OF THE WAR." & @CRLF & _
"" & @CRLF & _
"No one would have believed in the last years of the nineteenth century" & @CRLF & _
"that this world was being watched keenly and closely by intelligences" & @CRLF & _
"greater than man’s and yet as mortal as his own; that as men busied" & @CRLF & _
"themselves about their various concerns they were scrutinised and" & @CRLF & _
"studied, perhaps almost as narrowly as a man with a microscope might" & @CRLF & _
"scrutinise the transient creatures that swarm and multiply in a drop of" & @CRLF & _
"water. With infinite complacency men went to and fro over this globe" & @CRLF & _
"about their little affairs, serene in their assurance of their empire" & @CRLF & _
"over matter. It is possible that the infusoria under the microscope do" & @CRLF & _
"the same. No one gave a thought to the older worlds of space as sources" & @CRLF & _
"of human danger, or thought of them only to dismiss the idea of life" & @CRLF & _
"upon them as impossible or improbable. It is curious to recall some of" & @CRLF & _
"the mental habits of those departed days. At most terrestrial men" & @CRLF & _
"fancied there might be other men upon Mars, perhaps inferior to" & @CRLF & _
"themselves and ready to welcome a missionary enterprise. Yet across the" & @CRLF & _
"gulf of space, minds that are to our minds as ours are to those of the" & @CRLF & _
"beasts that perish, intellects vast and cool and unsympathetic," & @CRLF & _
"regarded this earth with envious eyes, and slowly and surely drew their" & @CRLF & _
"plans against us. And early in the twentieth century came the great" & @CRLF & _
"disillusionment." & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")