$re = '/^(.+)\/.*$/m';
$str = 'http://google.com/foo
http://google.com/a/b/c/bar';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);