#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "@(\"[\w\s]+\")|(?!@(\w+)@(\w+))@(\w+)"
Local $sString = "There is @key1 apples on the table. " & @CRLF & _
"There is @"key1" apples on the table. " & @CRLF & _
"There is @key 4 apples on the table." & @CRLF & _
"There is @"key 4" apples on the table." & @CRLF & _
"" & @CRLF & _
"There is @key@key2 apples on the table." & @CRLF & _
"There is @key3 apples on the table. (second step)" & @CRLF & _
"" & @CRLF & _
"There is @"key @"key3"" apples on the table." & @CRLF & _
"There is @"key 4" apples on the table. (second step)" & @CRLF & _
"" & @CRLF & _
"There is @"key @key3" apples on the table." & @CRLF & _
"There is @"key 4" apples on the table. (second step)" & @CRLF & _
"" & @CRLF & _
"There is @"key @key3 " apples on the table." & @CRLF & _
"There is @"key 4 " apples on the table. (second step)" & @CRLF & _
"" & @CRLF & _
"There is @"key @"key3@key7"" apples on the table." & @CRLF & _
"There is @"key @"key32"" apples on the table. (second step)" & @CRLF & _
"There is @"key 21" apples on the table. (3rd step)" & @CRLF & _
"" & @CRLF & _
"There is @key@key2@key3@key4 apples on the table." & @CRLF & _
"There is @key@key2@key35 apples on the table. (second step)" & @CRLF & _
"There is @key@key26 apples on the table. (3rd step)" & @CRLF & _
"There is @key7 apples on the table. (4th step)" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")