# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r'(\b\w{0,2})?\b'
test_str = ("http://www.youtube.com/watch?v=qsXHcwe3krw\n"
"http://41.media.tumblr.com/tumblr_lfouy03PMA1qa1rooo1_500.jpg\n"
"enfp and intj moments https://www.youtube.com/watch?v=iz7lE1g4XM4 sportscenter not top ten plays https://www.youtube.com/watch?v=uCdfze1etec pranks\n")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur'' to prefix the regex and u"" to prefix the test string and substitution.