import Foundation
let pattern = #"href=[^>]+>(*SKIP)(*FAIL)|my"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
This is a sample my text <a href="https://test.com">test my stuff</a> with my inside <a href="https://mytest.com">test me</a> brackets and my outside brackets oh my . <a href="https://test.com">test my stuff</a> not sure why my instances of my before the last lookahead doesnt work?
Intent: I have an FAQ that uses js to highlight words on the page by letter as you type. I need to ignore the HREF entries in the replace function as the injection of a class to highlight the typed letters/words replaced within the HREF messing up the link.
Incorrectly Ignoring position 18, 76, 141, 164
Correctly ignoring position 58, 104 and 201
Correctly finding position 227, 242
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)