$re = '/^(.+[_.-])?ad[sxv]?[0-9]*[_.-]*\..*\./m';
$str = 'ad.nl
ad.domein.nl
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);